Client's GMB Listing Is Published But Is Not Appearing In Maps

MeganR

Forum Member
I would love some feedback on this one. I have never seen this before. My client's GMB listing is published, not suspended, and yet it does not appear in maps.

This is NOT a "ranking issue," where it simply doesn't have enough "juice" to appear; rather, it LITERALLY does not appear.

When you on "See On Maps" in GMB console, it takes you to a blank listing.

Also, if you manually search for the exact business name in Maps it does not appear.

I'd like to attach screenshot, but it won't let me use attachment here.

I'm a noob to LSF. Do you have to do a certain # of posts before you can add attachments to a new thread?
 

MeganR

Forum Member
I'm cleaning up a mess left by their former SEO. I certainly don't want to be evasive, but I'd rather not disclose business, as the other SEO spammed the business name in the listing. We are just beginning onboarding process and they were wondering why their listing wasn't showing.

Their prior SEO had also built out a G Website Builder Site, but never published. So, this listing has been sitting here with an unpublished G Website, despite having a full WP website which is live on the web. Uncertain if this may be the cause--unpublished G site in account.

I understand if you can't provide advice without seeing the listing, believe me I get it. Just wondering if anyone on here had ever seen anything like this. Again, I'm amazed it's NOT suspended b/c prior SEO added location and specialty to biz name.
 

Colan Nielsen

1
Staff member
Administrator
It's definitely hard to diagnose and provide a solution without seeing this specific case. You mentioned that you were trying to add screenshots. Out of curiosity what type of screenshots were you trying to share if you can't disclose the business?

Sent from my XT1650 using Tapatalk
 

Linda Buquet

1
Staff member
Moderator
I'd like to attach screenshot, but it won't let me use attachment here.

I'm a noob to LSF. Do you have to do a certain # of posts before you can add attachments to a new thread?
Sorry I missed this Megan. Being new isn't the issue Megan. Likely either screenshot is too large OR non-supported file type.

I assume you clicked the picture icon in the menu right above the post edit screen.
Can you try again? Then give us any error message so we can try to help?
 

MeganR

Forum Member
Sorry, for the delayed reply. Colan, the image probably isn't that helpful as it's basically the map listing with a blank blue space, where the business name should appear. Linda, I tried to attach the image again, in .jpg and .png and compressed image. I'm wondering if it's a browser issue; I use chrome. I'll try sending from Firefox. I'm able to choose the file and select "upload" but nothing happens.
 

JoyHawkins

1
Staff member
Administrator
What happens when you press the see it on search button in the dashboard - does that pull the listing up properly?

If so, use the Get Five Stars plugin in Chrome to get the Maps URL (you'll need the listing up in search) and then open that up and it should show the listing on Maps.
 

Local Search Forum Info


Weekly Digest
Subscribe/Unsubscribe



Google top contributor


Follow Us on Twitter
@LocalSearchLink

local-search-ranking-factors

MyCommBanner250

Top