Getting 500 Error on Google+ Local Business Page?


Joined
Jun 28, 2012
Messages
14,436
Likes
4,292
There have been quite a few reports of 500 errors either when verifying your Google+ Business page to merge with your Google+ Local page or sometimes even just when managing your G+ page.

Google thought they had the issue fixed, but problems started cropping up again, so wanted to let you know.

500 Error when trying to verify social local Google+ page?

Quotes from Jade and and timelines of the issue below

ORIGINAL 8/15 Seeing reports of users getting 500 errors when attempting to verify their social local Google+ page. The team's aware and working on it. I'll post back on this thread with updates.

Update 8/17: Now I am also seeing reports of users getting 500 errors when trying to manage their verified page. Similar, but different issue -- team's looking into that one, too!

Update 10/17: I think that the 500 errors when attempting to manage pages should be gone. Can anyone confirm?

Latest Update 11/2: Seeing additional reports of 500 errors when folks try to manage their verified social pages. We thought that was fixed, but taking these examples to the team.

Still investigating the 500 errors when verifying, thanks for your patience!
I'll keep an eye on that thread and let you know when Jade reports back with a resolution or new updates.

Is anyone here having this or similar problems?
 
Joined
Jun 28, 2012
Messages
14,436
Likes
4,292
I may have discovered part of the bug or at least a new symptom of the growing 500 error problem.
New complaints just keep coming in and I checked some of the recent listings and found a common denominator/problem.

See thread: 500 Error when trying to verify social local Google+ page?

I just posted the following:

I just noticed a MAJOR problem all the most recent links posted above share in common.

All just have country showing. NO CITY or Address at all.

Looks like some have address hidden which is fine, but even when address is hidden, the City, State still should show.
I only checked about the last 5 or so and for address they all just have United States and then one above that just has Italy.

I'll escalate to Google again and let them know that this MAY be part of the bug or possibly even the reason you are all having this problem.
I just reported it to Google, so hopefully that helps them track down the bug and whack it!
 
Joined
Jun 28, 2012
Messages
14,436
Likes
4,292
ACTUALLY need to correct myself on something above.

"Looks like some have address hidden which is fine."

My head is still in the old Google Places world sometimes. What I meant is it's fine to hide your address and you NEED to on Google Places/Google+ Local pages to comply with the guidelines if you meet the listed criteria and do not see customers at your location. AND if you hide address on a Google+ Local it should then show your City, State.

HOWEVER looks like most of the recent ones I checked may be service area businesses with address hidden.

Businesses with hidden addresses WERE NOT supposed to merge/verify with a Google+ Business page yet. So this is likely a big part of the problem.

In Jade's original announcement at the Google Business forum about the new verification option it said:

"What about if I’m a service area business with hidden address?
The new verification process does not currently support service area businesses with hidden addresses."


But as I just told Google it should have CLEARLY spelled that fact out in-product! There are MILLIONS of business who did not happen to see that post in this forum or read all my posts about it either. SO if Google does not give a warning or something right in the product or even in help docs anywhere, how are business owners supposed to know they can't merge yet?
 

Nick Rink

Forum Member
Joined
Jul 20, 2012
Messages
88
Likes
18
Just tried the /b/ parameter trick and it doesn't work for our clients page, just sends us to a 404 Page (which I wasn't expecting). The Hootsuite trick seems to work fine for posting updates, just can't make any edits to the page at the moment.

Thanks for keeping us all up to speed on the possible workarounds until Google figures out a way to fix it.
 

Similar threads


Local Search Forum


Weekly Digest
Subscribe/Unsubscribe


Google Product Exert

@LocalSearchLink

Join Our Facebook Group

Top