Knowledge Graph Profile Picture Stuck on a Dumb Image

obcted

Member
Joined
Jan 30, 2013
Messages
43
Hello All,

I'm having a problem with having an old blog article's image as the profile pic in the knowledge graph. I've gotten ahold of google twice via phone and each piece of advice they've given me didn't do it.

Search term: "The Mckenzie Firm"

Darn supreme court building is there. It's pulling from the website - So I deleted it there and set his MyBusiness profile page as the main image but still no luck.

Anyone have this problem before and or know how to fix it?

Ted
 

Eric Rohrback

Moderator
Joined
Oct 3, 2012
Messages
1,020
I flagged the image within Maps, since it's now a blank page when someone tries to view the image. Not sure how long that will take.

What advice did Google give you from your phone calls that didn't seem to help?
 

obcted

Member
Joined
Jan 30, 2013
Messages
43
Thanks for the assist.

The first guy told me to flag it via the "feedback" on the bottom of the knowledge graph. He also then told me how it's somewhat algorithmic and that I should probably pull the image. It wasn't a popular post so I removed the image entirely. He said give it 3-4 for days and google will stop caching it (which they haven't).

Second guy told me to go into the mybusiness dashboard and set a new profile picture. Which I did. He said maybe the old one wasn't big enough. Which could have been the case but I don't think so. Long story short it's been 3-4 weeks and the image is still cached in the kg and maps.

Pretty annoying. Is there a better way to handle this?

Ted
 

obcted

Member
Joined
Jan 30, 2013
Messages
43
Hi Joy - thanks for the insight here. Sadly Google doesn't provide this option for the three accounts I test this on. It might only give you one bite at the apple per account. I was about to create a new gmail account to see if I can try on a "clean" account but when I searched I see the supreme court image is down.

I think it must have been Eric's Contribution. Thank you very much for the assist here.

Here's what shows up on when I follow the steps in this link:
How to Report Photos in your Google Business Page - Online Ownership

screenshot.7.jpg

This is actually how I talked to Google rep the first time. They must have either just removed this feature or either flagged my ip (for bothering them too much) or cap out account with the number of customer serive requests. Either result is pretty frustrating considering neither option the reps told me actually fixed the problem.

Thank you for all your help though :)

screenshot.7.jpg
 

Eric Rohrback

Moderator
Joined
Oct 3, 2012
Messages
1,020
Yeah, i'm not seeing the supreme court image either. While I doubt my report helped all that much, I think the sum of all reports to the same image made an impact. I guess the takeaway here is to make sure multiple people report the error to push it along. I think removing the image from the site also helped the case, since it was leading to a 404 error and displaying as a blank screen within maps.
 

DanLeibson

LocalU Faculty
Joined
May 17, 2013
Messages
225
I think reporting this stuff via the image feedback mechanism is the best way to get stuff like this removed. Just hit it with a bunch of reports and that should get it resolved. Brands have to deal with this stuff all the time, check out slide 12 for my favorite example:

What About Us? Local SEO & Multi-Location Businesses
 
Last edited:

Shane Pollard

Member
Joined
Sep 3, 2016
Messages
9
Another Helpful thread on the forum. Thanks for the advice had a similar issue with street view showing irrelevant building. Reporting the problem worked. 10 days wait time.
 

Weekly Digest

Weekly Digest
Subscribe/Unsubscribe

Trending: Most Viewed

  Promoted Posts

New advertising option: A review of your product or service posted by a Sterling Sky employee. This will also be shared on the Sterling Sky & LSF Twitter accounts, our Facebook group, LinkedIn, and both newsletters. More...

  Local University Guide

Google Product Exert


Top