Known Technical Issue Impacting GMB Photos

Barry Zuber

Member
Joined
Jul 26, 2013
Messages
20
Hello. I am experiencing the problem with one account. Has anyone seen an update that it's been fixed?
 

KimW

Member
Joined
May 14, 2019
Messages
16
Hello,
I am having this issue with several Google My Business listings. I've contacted GMB support and they always say the issue has been resolved yet photos do not show live. I even asked Moz Local for help, they said they cannot.
Any updates on why this is happening??
 
Joined
Oct 17, 2018
Messages
114
I don't know if it is a "solution necessarily, but we had this same issue with multiple listings recently and we ended up getting around the problem.

So each of the listings had multiple photos uploaded (even new cover/logo photos set) and none of it was showing out on the KP- it was still just the streetview and the same old 2/3 photos that were already there previously. We deleted what we uploaded that wasn't going live, then re-sized the photos to be 720x720 and reuploaded them. Each listing that we did this one had the photos showing out on the KP within ~1 hour roughly.

So it doesn't solve the root issue really, but it did accomplish the goal of getting the photos published.
 

KimW

Member
Joined
May 14, 2019
Messages
16
I'm at a loss. GMB support insists photos will go live within the Photo section but they never do. However, they are now publishing to Posts with no ability to remove. <facepalm>
 

Mindquest

Member
Joined
Jul 10, 2013
Messages
61
Just adding to the thread I am having the same issues and detailed it here.


@Cordell Crowley Tried your resizing hack but no luck.

Hopefully this is being worked on.
 

sarmcl

Member
Joined
Jul 7, 2017
Messages
78
Just adding to the thread I am having the same issues and detailed it here.


@Cordell Crowley Tried your resizing hack but no luck.

Hopefully this is being worked on.

I have resized to multiple different sizes and nothing is working. This is on MULTIPLE clients who all have separate GMB dashboards. We cant get anything to show up on the actual listing. Its frustrating. Support keeps telling us they are having specialists look at it but we get nowhere. I am at loss now.
 

HoosierBuff

Member
Joined
Dec 12, 2013
Messages
290
I have it with a client that recently uploaded 100 photos for their 100 different locations. What a nightmare.
 

sarmcl

Member
Joined
Jul 7, 2017
Messages
78
I have it with a client that recently uploaded 100 photos for their 100 different locations. What a nightmare.
Can I ask you what kind of photo was it? Logo? Building? Product? Trying to figure out why its filtering logos for sure.
 

sarmcl

Member
Joined
Jul 7, 2017
Messages
78
In my case, the photos were pictures of people (team photos) or logos.

Joy any thought to the new Bedlam update filtering out the logos for some reason? We have one very very well known company and the only photo they want is their logo. We can no longer get it to appear on the listing regardless how to post it(cover photo, logo, interior photo, etc)
 

  Weekly Digest

Weekly Digest
Subscribe/Unsubscribe

Trending: Most Viewed

  Promoted Posts

New advertising option: A review of your product or service posted by a Sterling Sky employee. This will also be shared on the Sterling Sky & LSF Twitter accounts, our Facebook group, LinkedIn, and both newsletters. More...

  Local University Guide

Google Product Exert


Top