Ongoing bug with Google posts? ๐Ÿ›

Joined
Aug 14, 2018
Messages
37
I have various posts showing in the front end that haven't actually been made in the GMB dashboard - the business profile is just showing uploaded images as posts.

Example: Preseli Venture - Google Search

1576076255333.png


Thus isn't a post - it's just an image upload - there are quite a few of these showing as historical posts - anyone else having this issue? Thanks! Claire ๐ŸŽ„
 

Thompsonpaul

Member
Joined
Jan 7, 2019
Messages
4
Also found it on quite a number of restaurants and other business here in my small town in Canada when I was doing some research today.
 

Peter

Member
Joined
Oct 17, 2019
Messages
6
It is one type of post from mobile-only. You can't find it on the dashboard from the website view. I have tested myself on this. Quite interesting.
BTW, not quite sure if affected by this update, I have observed images not showing on the map after uploaded since October.
 
Joined
Oct 17, 2018
Messages
106
Images not showing on the live Maps listing despite being uploaded has been a very annoying ongoing issue, yes. Typically a quick chat with G Support will get them pushed through manually thankfully.
 

Scott Rawlins

Moderator
Joined
Nov 14, 2012
Messages
1,049
A little different, but yesterday I noticed a client that wasn't showing any G Posts since 10/31 in the KP, even though they showed in GMB and even had view numbers. Added one and that one showed immediately, but all other posts weren't showing at all when selecting "view all". Then today, they're all back to normal.

Another client today simply doesn't have the "view all" option or any past Posts showing at all, even though there are plenty that have been added every week.. Going to add another and see what happens.

Odd.
 
Top