Unable to hide address?


Joined
Oct 17, 2018
Messages
17
Likes
11
I noticed today that you are no longer able to hide your address in the GMB dashboard? I didn't know if this feature had been implemented for a while and I just had not encountered it or if it was new.

Had a client (a florist) request their address be hidden and realized the ability to do that in the address field was gone. Checked a handful of other clients' dashboards just to check if it was a one-off or not and it is the case for each listing.

address-gmb-dashboard-png.3462
 
Joined
Oct 17, 2018
Messages
17
Likes
11
Google has disconnected the service area from the address. What you need to do is clear the address info to hide the address. Then enter some service areas if you have not already done so.
I knew they had disconnected the service area from the address, but didn't realize the option to hide your address had been changed as well.

Yan is correct, also as a side note, after you clear the address if you put it back in you will have to reverify again.
This is good to know! It's good to have a heads-up that we'll need to reverify the listing if we hide the address this way. I'm assuming that it is a PC re-verification.

Thanks for the help, all.
 

Similar threads


Local Search Forum


Weekly Digest
Subscribe/Unsubscribe


Google Product Exert

@LocalSearchLink

Join Our Facebook Group

Top