Easiest option to index page?

mikepcservice

Member
Joined
Jun 6, 2018
Messages
238
Hey guys, I am having an issue indexing new blogs in GSC. First I try to add the blog's url via Add Property which opens the Select Property Type box, I paste the blog url and hit Continue but nothing happens, help please?

Screen Shot 2020-02-04 at 11.17.07 AM.png
 

djbaxter

Administrator
Administrator
Joined
Jun 28, 2012
Messages
3,113
I may be wrong but I think if you're using domain you just use bestheatingrepairsservice.com (no https://) nut depending on your server configuration that doesn't always seem to work.

Try adding the full URL as you've done in your example into the right box.
 

pony

Member
Joined
Jun 26, 2019
Messages
124
You don't submit URLs to be indexed by adding properties. From your screenshot it looks like you selected an option to add a new domain to your GSC account, which is what Google calls a property.

If you want to submit a URL for indexation just inspect the specific address using the search bar at the top of your GSC account. When reviewing the inspection results you will see an option to index the page if it is not already indexed.
 

Eric Rohrback

Moderator
Joined
Oct 3, 2012
Messages
1,017
From the screenshot it looks like you're trying to add a new property, not fetch a page from an existing property. Have you been verified as an owner or been delegated full access to GSC for the site you're looking to work with?
 

mikepcservice

Member
Joined
Jun 6, 2018
Messages
238
If you want to submit a URL for indexation just inspect the specific address using the search bar at the top of your GSC account. When reviewing the inspection results you will see an option to index the page if it is not already indexed.
When I enter the blog URL then hit Enter, the avocet screenshot shows what happens. That is why I tried adding the blog url as a property.

Screen Shot 2020-02-04 at 12.27.14 PM.png
 

pony

Member
Joined
Jun 26, 2019
Messages
124
The blog you are trying to index is a HTTPS url and you are looking an HTTP version of the domain. In Google's eyes your HTTP and HTTPS versions of your site are separate properties.

You need to verify the HTTPS version of your site and index it from there. On that same note, if all of your URLs use HTTPs then the data you are looking at in your HTTP profile is moot. If you have your website split across both protocols, upgraded them all to HTTPs would be top priority for me.
 
Last edited:

mikepcservice

Member
Joined
Jun 6, 2018
Messages
238
From the screenshot it looks like you're trying to add a new property, not fetch a page from an existing property. Have you been verified as an owner or been delegated full access to GSC for the site you're looking to work with?
Yes should be, since the pages was being indexed a while back.
 

mikepcservice

Member
Joined
Jun 6, 2018
Messages
238
The blog you are trying to index is a HTTPS url and you are looking an HTTP version of the domain. In Google's eyes your HTTP and HTTPS versions of your site are separate properties.

You need to verify the HTTPS version of your site and index it from there.
My God, so simple. All I had to do was select the https option from the Properties drop down tab, that did it. Thanks a million!

I think what caused this was the site was functioning without an SSL for the past few months but since last month when the SSL was installed that's why the https became an issue for this.
 

  Weekly Digest

Weekly Digest
Subscribe/Unsubscribe

Trending: Most Viewed

  Promoted Posts

New advertising option: A review of your product or service posted by a Sterling Sky employee. This will also be shared on the Sterling Sky & LSF Twitter accounts, our Facebook group, LinkedIn, and both newsletters. More...

  Local University Guide

Google Product Exert


Top