Issues claiming/creating listings?


Cordell Crowley

Forum Member
Joined
Oct 17, 2018
Messages
34
Has anybody else been having issues with getting listings claimed or created? We've been having error messages of "Sorry, we are having issues at the moment" like in my screenshot pop up since roughly Thursday last week anytime we try getting ownership of a listing through all methods: Claiming unclaimed listings, Attempting to start a change of ownership process for claimed listings, Creating a new listing from scratch. The error happens randomly at different steps of the setup/claim process: sometimes at the beginning, sometimes in the middle, and sometimes at the end when you hit the finish button.

Our sister company that has a different IP address and a different agency dashboard account has been having the issue also, so it seems doubtful it's an IP or Google agency account issue. It's been incredibly frustrating since roughly 4 out of 5 businesses we try setting up on Google has not worked, so all we can really do is make our notes and try again another day. Looking to find if it's just an "us" issue or if Google is having issues that are affecting other people as well.

 

Cherie Dickey

Local Search Expert
Joined
Jan 30, 2018
Messages
154
I had this issue with one account I was trying to request ownership of a duplicate for... but I haven't had it with any other accounts, so I rationalized it as being an issue with the duplicate listing itself (since I couldn't get it to come up as an option during another method I had tried).
 

Cordell Crowley

Forum Member
Joined
Oct 17, 2018
Messages
34
UPDATE: We've found that setting the listings up the old-fashioned way through individual emails is working just fine, so it seems to be an agency-specific issue. If anybody else runs into this issue, any insight is welcomed.

We've been setting our clients up the old-fashioned way as a temporary workaround but it would be very inconvenient for the agency account to have any lingering long-term issues, as it's been really solid overall the last few months for us.
 

Cordell Crowley

Forum Member
Joined
Oct 17, 2018
Messages
34
This is a known issue with the agency dashboard. Google is aware of the issue but appears to only be fixing it on a case by case basis.
Interesting, it's the first time we have run into this issue and we've been using it at both of our companies since mid-September. Guess we've been lucky.
 
Joined
Oct 11, 2012
Messages
67
Yes. It appears to be spotty but seems to only be resolvable by Google when it does occur. I saw one agency experience it last week and another this week. Both have been fine, right along
 

Cordell Crowley

Forum Member
Joined
Oct 17, 2018
Messages
34
Yes. It appears to be spotty but seems to only be resolvable by Google when it does occur. I saw one agency experience it last week and another this week. Both have been fine, right along
What would be the best way to contact Google about this issue? We typically call the GMB Support for issues with individual listings, so I wasn't sure if there was a better contact method for an agency dashboard-specific issue like this.

Thanks for the help!
 
Joined
Oct 11, 2012
Messages
67
I am not sure.

Try @googlemybiz on Twitter. If they can’t help raise it in the forum and joy or Colan or I can escalate it.
 

danaparker

Forum Member
Joined
Sep 26, 2018
Messages
1
I am having the same issues with the Agency Account. I cannot claim existing listings either, the page just never loads.
 

Similar threads


Local Search Forum


Weekly Digest
Subscribe/Unsubscribe


Google Product Exert

@LocalSearchLink

Join Our Facebook Group

Top